Ripro主题小工具显示区块受错误影响,可能无法正常运行问题2种解决方案

渡仁智享-专注优质互联网资源分享

由于WordPress的版本更新,WordPress5.8的小部件使用区块方式编辑,完全改变了小部件编辑方式,小工具使用的Ripro主题的小工具就开始罢工了!

每次添加小工具就会提示““cao_widget_pay”区块受错误影响,可能无法正常运行。请检查开发者工具以了解更多详情。”(如下图所示)

Ripro主题小工具显示区块受错误影响,可能无法正常运行问题解决方案

Ripro小工具无法正常使用解决方案

Ripro主题小工具显示区块受错误影响,可能无法正常运行问题解决方案

 

第一个方案:安装classic widgets

打开安装插件页面,搜索“classic widgets”

Classic Widgets是一款恢复经典小部件的WordPress插件。当下 WordPress5.8版本更新了小部件的功能,很多人不习惯的话就可以使用这个插件回到过去。

1、Classic Widgets安装启用

登录WordPress后台 > 插件 > 安装插件,搜索“Classic Widgets”,安装并启用。

国内服务器可能会出现无法正常安装的情况,那就手动从 WordPress官网下载,再用ftp软件上传到网站的插件目录,在WordPress后台启用。

2、Classic Widgets使用

插件激活后就会恢复过去的经典 WordPress 小工具设置界面,并禁止使用区块编辑器管理小工具。本插件不提供也无需配置,通过启用或禁用此插件,就能在经典小工具和区块小工具两种界面中来回切换。Classic Widgets是由 WordPress 官方插件,计划维护至2022年或更久的时间。

选择第一个“经典小工具”,安装,启用,重新设置小工具,清理缓存

Ripro主题小工具显示区块受错误影响,可能无法正常运行问题解决方案

再次到前台查看,已经可以正常使用!

Ripro小工具无法正常使用解决方案
Ripro小工具无法正常使用解决方案

 

另发现Ripro的支付购买小工具虽添加成功,但是刷新后就没有了。还是不完美!正在考虑寻求其他方案解决,初步打算是WordPress直接降低版本

如果你所使用的wordpress主题或者wordpress插件作者或者开发商不断地测试新版本的wordpress,并同步wordpress进行测试和适配升级,那么你就可以毫无压力的对wordpress升级并且对插件和主题进行升级,以得到更好的更安全的版本。

第二个方案:WP Downgrade插件对wordpress的降级处理

如果你的主题和插件作者或者开发商并不是一直在维护,那么就有可能出现主题或者插件对新版本的wordpress造成不兼容的情况出现,特别是你已经升级到了高版本,插件或者主题才出现问题,那么你就需要进行wordpress的降级处理。

在此之前,如果你对服务器、虚拟主机有所了解,那么你可以使用ftp或者ssh对你的wordpress进行覆盖,下载旧版本的wordpress(wordpress中文官网可以下载到以往所有的wordpress版本),将除了wp-content以外的文件全部覆盖,即可完成手动降级。

如果你对这些不懂得话,可以使用 WP Downgrade 插件进行降级。

这里需要你注意的是,一定要备份好你的文件和数据,在进行升级或者降级时,备份的工作是必不可少的,以防止出现错误而丢失数据那就非常麻烦了

在wordpress后台–插件–安装插件搜索 WP Downgrade 并安装插件启用:

Ripro主题小工具显示区块受错误影响,可能无法正常运行问题解决方案

进入 WP Downgrade界面:

Ripro主题小工具显示区块受错误影响,可能无法正常运行问题解决方案

进入界面可以看到如下设置选项:

Ripro主题小工具显示区块受错误影响,可能无法正常运行问题解决方案

下面的红色提示是表示不能链接到中文版本的wordpress链接,因此你可以将语言切换到英文进行降级,在设置–常规中新开一个窗口,切换一下语言(新开之后不要关闭):

Ripro主题小工具显示区块受错误影响,可能无法正常运行问题解决方案

切换完成之后回到 WP Downgrade界面进行降级,降级完成之后,在设置–常规这个界面将语言更改为简体中文即可恢复好中文版本。

这样我们的wordpress降级就完成了。

在这里还是要最后提示一下,在降级之前,备份好你的数据和文件,以备在出错时可以及时的使用备份进行恢复网站,

查看wordpress新版本是否有安全性的更新,如果有,建议你不要降级,而是寻求帮助将你的插件或者主题进行适配更新,或者更换同样类型的主题和插件,因为安全性还是第一位的。

总而言之,备份是必不可少的步骤,还请大家一定要注意!

最终解决方案:

选择了降低WordPress 的版本,现在已经设置为:5.7.2,现小工具已经可以正常使用

 

渡仁智享 Doren Share & Share Doren 原创文章转载或复制请以超链接形式并注明出处,谢谢!(www.doren.cn)
渡仁智享-享你所想 » Ripro主题小工具显示区块受错误影响,可能无法正常运行问题2种解决方案